Crashes on M1 MacBook Pro... Expected?

I’m setting up my new M1 MacBook Pro. I see that Lightfield Studio seems to be unhappy. When I try to run it, nothing seems to happen for about 15 seconds, and then I get the application crash screen.

Is this a known issue on the M1 platform?

Also, as an aside, I’m surprised to see this identifier (“yourcompany”). :smile:

Process: LightfieldStudio [10415]
Path: /Users/USER/Desktop/LightfieldStudio.app/Contents/MacOS/LightfieldStudio
Identifier: com.yourcompany.LightfieldStudio
Version: 0
Code Type: X86-64 (Translated)
Parent Process: ??? [1]
Responsible: LightfieldStudio [10415]
User ID: 501

Date/Time: 2021-04-06 14:39:50.131 -0400
OS Version: macOS 11.2.3 (20D91)
Report Version: 12
Anonymous UUID: EE0E7BEC-95F4-6B55-13C7-F98B03B40BD1

Time Awake Since Boot: 6400 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Illegal instruction: 4
Termination Reason: Namespace SIGNAL, Code 0x4
Terminating Process: exc handler [10415]

Application Specific Information:
/Users/marc/Desktop/LightfieldStudio.app/Contents/MacOS/LightfieldStudio

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 com.yourcompany.LightfieldStudio 0x00000001005d8a64 0x1004d6000 + 1059428
1 dyld 0x0000000200a87079 ImageLoaderMachO::doModInitFunctions(ImageLoader::LinkContext const&) + 559
2 dyld 0x0000000200a87478 ImageLoaderMachO::doInitialization(ImageLoader::LinkContext const&) + 40
3 dyld 0x0000000200a81d1a ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, char const*, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 492
4 dyld 0x0000000200a7fb82 ImageLoader::processInitializers(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 188
5 dyld 0x0000000200a7fc22 ImageLoader::runInitializers(ImageLoader::LinkContext const&, ImageLoader::InitializerTimingList&) + 82
6 dyld 0x0000000200a6c62f dyld::initializeMainExecutable() + 199
7 dyld 0x0000000200a729a4 dyld::_main(macho_header const*, unsigned long, int, char const**, char const**, char const**, unsigned long*) + 8288
8 dyld 0x0000000200a6b22b dyldbootstrap::start(dyld3::MachOLoaded const*, int, char const**, dyld3::MachOLoaded const*, unsigned long*) + 457
9 dyld 0x0000000200a6b025 _dyld_start + 37

I am Not a Programmer but If I am correct, then the Programm ist calling an Instruktion Set that ist not supported by Your CPU, the Sigill Error ist pointing in that Direction, at the Current state the new Arm Architecture will have more of these Problems I guess, since Most Programs are still optimized for x86 Instruktion Sets.

Thanks for the reply, Johannes!

Fortunately for me, I actually am a programmer, so I’m used to looking through crash reports like that. I was providing it as a reference to Leia’s developers.

I suspect that the issue is partially related to the app running in emulation on the new M1 Macs. Apple does not guarantee 100% compatibility, so this app, for whatever reason, just may not be compatible.

I could ask Leia to consider providing an M1 binary, but I can’t imagine that would be a priority right now. Also, given that the binary is unsigned, Leia may not be a registered developer with Apple, so they may be limited in their support of the new M1 Macs.

Anyway, this was just an FYI since I hadn’t seen anyone mention M1 Macs with Lightfield Studio.

One thing that is unusual, and could account for some issues, you are using the app from your desktop. macOS has different permissions when putting things into Applications compared to the app being somewhere else. Does it get further if you run it from Applications?

If it doesn’t work better from Applications, what happens if you use Finder’s Go menu, Go to Folder…, and go straight here:

/Applications/LightfieldStudio/Contents/MacOS/LightfieldStudio

Then you can run it as a Terminal process, and get a better look at what it manages to do before it crashes.

Thanks for mentioning Terminal. I tried running it from a shell prompt and through a bit of experimentation, it looks like it’s more likely to be a Rosetta 2 issue:

marc@Marcs-MacBook-Pro ~ % /Applications/LightfieldStudio.app/Contents/MacOS/LightfieldStudio                             
zsh: illegal hardware instruction  /Applications/LightfieldStudio.app/Contents/MacOS/LightfieldStudio

The reason I’m pinning it on Rosetta 2 is that this error happened very quickly each time I tried until I made a change. I noticed that this folder was still marked with com.apple.quarantine, so in case that was making any difference, I removed that attribute from that entire folder (tree). The next time I tried running the command, it still gave the same error, but it took about 10-15 seconds before it showed. I believe that during that time, macOS was doing its JIT handling of the x86_64 app with Rosetta 2.

1 Like