Can't access Unity SDK

Hi, I am trying to download Unity SDK, but stuck at EULA page after login, no response after click “I agree” button, what should I do?
Thank you

Let me see if I can help out here: Starting with the basics – what browser are you using?

Just worked on my side in Chrome.


Sorry. IE is not working for this, and the whole page is black.
Chrome and Edge have the same issue.

DarrenG via 3D Light field content creation and development forum by Leia <> 于2021年1月11日周一 上午9:15写道:

Hi, Darren

Thanks so much for reply.

I tried Chrome , Edge, and IE. They all have the same issue.

When I put my mouse on “I agree”, it turns black, as shown in agree2.png and the red circle indicated my mouse cursor.

Thanks so much,


Only other thing that comes to mind is maybe clearing the browser cache, restarting, and trying again. Failing that, I can reach out to the Web dev folks here and see what else could be happening.



Hi, Darren
I tried to clear both chrome and edge cache and restart, they are not working.
And I also tried three different computers and they all show the same problem.


Hey Lu,

If you just want to download the SDK, you can try it from here

Although if you want to upload an app to our store we would still need to figure out how to get you logged into

Let’s start with getting you the Unity SDK first and we’ll go from there. :slight_smile:

1 Like

Also Lu, one more check - is your browser set at 100% view? If it is lower, we have noticed there are some issues with accepting terms.

1 Like

Great! Thanks so much. I can download the SDK first.
Also my browser was set at 100% view. The same problem.

1 Like