Android SDK: needed by not found

Hi There,

So, I’m a web-dev by trade, with limited Native App Development experience, dipping my toes into the world of CPP, Java, Native Android etc… so please forgive any lack of simple understanding on display here…

I’m trying to add to a fork of the Citra 3DS Emulator on Android, and I’m currently stuck with this error:
C:/Users/X/AppData/Local/Android/Sdk/ndk/21.1.6352462/toolchains/llvm/prebuilt/windows-x86_64/lib/gcc/aarch64-linux-android/4.9.x/../../../../aarch64-linux-android/bin\ld: warning:, needed by ../../../../../../../externals/leia_sdk/lib/arm64-v8a/, not found (try using -rpath or -rpath-link)

My CMakeLists.txt looks like:

add_library(lib_leia_sdk STATIC IMPORTED)
set_target_properties(lib_leia_sdk PROPERTIES IMPORTED_LOCATION
target_include_directories(video_core PRIVATE
target_link_libraries(video_core PRIVATE EGL GLESv3 lib_leia_sdk)

The project itself uses GLAD, which I’m not familiar with, but, it seems to utilize EGL/GLES already?
However, even if I explicitly include:

#include <EGL/egl.h>
#include <GLES/gl.h>

I still get the same error.

I’ve detailed further information about the context of the issue here:

My code can be found here:

I’m happy to provide any more info that may be helpful in diagnosing/resolving this error.
Thanks in advance for your attention.

i figured it out, i needed to change GLESv3 to GLESv2


Awesome! Will Your Citra Build be for Download as compiled apk in Your GitHub?

1 Like

Here you go! let me know what you think:


Awesome! I’ll take a Look in the next few days, Thank You very mouch!

1 Like

Revisited Your latest Beta and I am impressed! Do You think there is room for improvement or more specific for a few more frames per Second on certain Games? By the way Zelda Runs pretty good!