Cannot output my Unity game using Leia Remote

Nice to meet you. This is my first question.

I’d like to output 4V game in Unity to my Lume pad using Unity Remote, but I’m having trouble doing it.
My computer is certified for the Lume pad, and when I press the play button in Unity, the Lume pad goes into 4V mode, but the game screen is not output.

I have added the SDK to my Unity game project based on this site(Quick Start Guide - Developer Docs), and I have also downloaded the Leia Remote and Unity Remote5 to my Lumepad.

Then, when I build and run the game in Unity, the game is correctly installed on my Lumepad and I can play it on 4V. Nevertheless, Unity Remote is not working properly.
I want to use Unity Remote as much as possible because it takes a lot of time to build the game every time.

The version of my computer is as follows:
Mac OS Big Sur 11.4

The version of Unity is as follows:
2020.3.12f

The version of Unity SDK that I downloaded is as follows.
0.6.18

Of course, I have Android Build Support installed, and the JDK, SDK, and NDK paths are all in place.

I’m hoping someone can help me out.
Thank you very much.

Thank you for your question, YouChicka-Oshi!

Based on your description, it looks like you followed the steps correctly and your computer is recognizing the Leia Device as expected. Let’s try this:

  • Confirm your Game View is set to the same resolution as the Lume Pad, either:
    • 2560x1600 landscape
    • 1600x2560 portrait
  • Follow our troubleshooting steps related to no content displaying on device here: Leia Remote - Developer Docs.

Hopefully these steps resolve your issue. If not, well work from there.

Cheers,

Joe

4 Likes

@joseph.lang Joe, thank you for answering my question!

I tried what you told me.
Then it appears on the screen for a moment, but it immediately returns to the main Unity Remote screen.

So I tried disabling the objects related to the Leia Remote in the Unity scene, and then I was able to play the game on the Lume Pad screen as I expected, although it is in 2D.

When I checked the Unity console, I saw the following two warnings. I think these may be the cause of my problem.

  • Ignoring depth surface load action as it is memoryless
  • Ignoring depth surface store action as it is memoryless

What should I do next?
Thank you very much.

This is a new issue we have not seen before. Let’s dig a little deeper into if this is an Editor specific situation.

I notice you are on Unity Editor version 2020.3.12f and the release notes for 2020.3.13f1 have a few Mac / graphics API bug fixes listed.

Let’s try this:

  • Update your editor to 2020.3.13f1

If that does not work:

  • Reply with your Editor Log file attached (right click console > Show Editor Log)

image

If upgrading does not work, I will try to replicate the issue on my side and use your editor log as a reference