Cannot show 3D object in lume pad when using Leia Remote

Hi, There
I based on the instruction on Youtube (LivePreview with UNITY (LeiaRemote): The Lume Pad as a 3D display second screen. - YouTube) to install UNITY SDK in lume Pad as a second screen.

When I press PLAY button, lume pad can show the same object, for example, a cube as unity in my PC.
But the problem is the cube in lume pad is still 2D not 3D. Are there some parameters I need to set? So I can show 3D object in lume pad when I generate object in my PC. Like this page Leia Remote - Developer Docs

Thanks so much,
Lu

Hi Liulu,
There’s several possible reasons it would show 2D instead of 3D, so I’ll list a few here you can try:

  1. Did you attach a LeiaCamera component to the camera game object in your Unity scene? This is the component that tells it to render that camera in lightfield mode. Documentation here: Getting Started - Developer Docs

  2. Did you add a LeiaRemote component to an object in your scene? (You probably did this if you followed the video, but make sure it’s there and enabled)

  3. Is the LeiaDisplay component in your scene set to lightfield mode off instead of on? This would cause it to render in 2d.

  4. Also make sure in edit > project settings > editor that:

  • Device is set to Any Android Device
  • Compression is set to PNG
  • Resolution is set to Normal
  1. Make sure the game window resolution is set to the resolution of the device (2560 x 1600 for LumePad)

  2. Make sure your LeiaCamera component’s baseline scaling value is sufficiently large to perceive depth. The smaller this value the less depth you will see, with a zero value giving you 2D.

5 Likes

Thanks so much for these tips. They are very helpful.
It is working now.

2 Likes