Not getting any 3D effect

Hi,
I’m just adding cubes to the Sample Scene… I assume I’ve missed a step. The cubes are not 3D on the phone’s display. Just 2D, but with that lenticular lens effect that tells me that it’s in 3D mode.

Here’s an image of my Unity setup with the camera selected.

@tuck Are you using Unity Remote or are you packaging the app and installing the .apk on the device?

If you’re using Unity Remote, you also have to use the LeiaRemote app from the Leia Developer portal to ensure the backlight is turned on, otherwise the interlacing will show with the standard 2D backlight instead of the Leia Diffractive Lightfield Backlight.

Thanks Nima.
Interesting. I am using the LeiaRemote app, which required the installation of Unity Remote 5.
I could perhaps package up the scene and run the .apk I guess. Would that ensure better performance of the 3D effect?

When I built it to device, the 3D effect didn’t turn on. It was in 2D mode.

The 3D effect really works well when built to device. It seems that it’s only the LeiaRemote app that is not displaying as advertised.
But at least I can get it to work now.

I think the script for 3d in a build APK is different from the LeiaRemote script for building the app inside Unity.

That would explain what I’m seeing. The 3D effect is still not working when using LeiaRemote for me.

Do you see an image on the device when using the remote tool or can you see the image and just the 3D is not working? This will help me know if it is a Unity Remote issue or a bug in the SDK.

Try using using this version of the LeiaRemote.cs script. https://drive.google.com/file/d/1gA_pDW67mJ0wraYJUs1BWq691UHFMrN0/view?usp=sharing

Also In the Project Settings -> Unity Remote settings change Compression to PNG instead of JPG. If the image uses JPG compression the image will not be pixel perfect which is necessary for the image to be viewed on the device correctly.

The image (3 cubes) appears on the device. However they’re not 3D. They’re your standard 2D image.
When I build the .apk and run that, the cubes are all fully “holo” 3D. It’s super cool when it works.

1 Like

Finally got it to work.
There is a setting in Project Settings/Editor called Unity Remote/Resolution. My setting seems to have been set on “Downsize” and this seems to have been preventing LeiaRemote from showing the true “3D” effect in remote mode when playing in Editor.
Changing this setting to “Normal” seems to have fixed it.
Thanks for all your help everyone.

2 Likes