Leia appstore doesn't load, and when it does, doesn't login

The other day opened Leia appstore and it was strange, it said there was an error and try again, but on the screen there was a loading percentage for an update. Once finished the update, the same error message and nothing happened, after a few tries it loaded, but then it was impossible to log in with Google. I deleted cache and data, and solved the program not loading, but doesn’t solve the problem with login. When I push the Login with Google button, the screen blinks for a second and return to the same screen.
After various restarts it happened again, the app doesn’t even load. See screenshot:

I restored All apps settings, deleted data and cache from Leia appstore again. And it oppened. The sign in with Google button worked, selected my account and… That didn’t work, Try again

When I push the button again the screen blinks for a second and then stay black this way:

Are you on the latest version of the app store? (v2.0.498)

1 Like

Yes 2.0.498

As you’ve already tried clearing the cache, deleting data, and rebooting the device, I can only assume the app got corrupted during the update process. I think Leia might need to provide you with a link to the latest apk so you can reinstall the app.

1 Like

@Kano3D do you know if you have a US or EU version of the pad ?

How can I know?

Goto Settings - About tablet - Build number: does it end with Rest of World (_RoW)?

Yes, it ends with RoW, thank you.

Solved: Deleting google account from device allows to login on Leia appstore normally