Leia apptore - can't login on EU hardware?

Hi. I got a used Lume Pad that uses the EU firmware. I’m having problems logging into the Google account on Leia appstore. I can’t download anything.

1 Like

I have just tried (I’m in Italy) and everything works smooth. Usually I do not insert username and password but I simply click on log by google button.

1 Like

Thanks Marco. At least I know it is not incompatible. When I press the login button, I get the message “Hmmm doesn’t seem to work. Please login again. Try again.” I also tried the login in the AppStore settings, which also gives me an error.

I made sure to use the most recent firmware.
Build number LUME_UI_1.3.1_LPD10_EU

I tried rebooting.
I tried leaving the pad alone overnight.
I tried logging out of my Google account from the pad settings menu and logging in via the AppStore.
I tried logging in with another Google ID.
I tried logging in two different Google accounts at the same time.
I tried deleting app preferences.

None of them worked so far.

Best regards,

OK the Lume Pad tech support help me fixed it. Here are the steps they gave me:
"1. Long press appstore icon
2. Click the info button
3. Force Stop the application
4. Clear storage and data button
5. Clear Storage
6. Re-launch the application
App should now update to build 2.1.513

Please let us know if this helps!

Kind regards,

Leia Inc. Customer Support"

1 Like

Welcome to the Lume Pad community @360rumors!

Can’t wait to see what you think of VR180/360 content through LeiaTube!

1 Like