Leia Account Login Issues: Instruction to Fix

Hey everyone,

We’ve been having some issues on our end with Leia Accounts on Lume Pad 2 and Nubia Pad 3D, and while we’ve been doing our best to fix them, it’s been a game of whack-a-mole and some users are still experiencing problems after the fixes on our end.

For that, we’ve come up with a nearly 99% effective way of fixing the Login issues if you follow the below steps EXACTLY and IN ORDER:

  1. Remove all Leia Accounts on your tablet from the Settings app > Users and accounts > Accounts for [Your Username]
  2. Launch Leia Appstore > Ensure you’re signed out
  3. Close the Leia Appstore app (force close using App Switcher / square button in Home Bar)
  4. Clear the Leia Appstore storage: Long press Leia Appstore app icon → App Info → Storage & cache → CLEAR STORAGE
  5. Clear all data Chrome (not just cache): Long press Chrome app icon → App Info → Storage & cache → MANAGE SPACE → CLEAR ALL DATA
  6. Launch the Leia Appstore
  7. Attempt to sign in with your Leia Account

Please make sure to follow these steps exactly.

If it doesn’t work, try again.

If you’re tried it twice and it STILL doesn’t work, please reach out to help@leiainc.com and let our customer service team know so that we can find out what is unique about your situation and help fix that bug too. Or, there’s a chance it’s a new issue on our server side, in which case we’ll let you know we’re fixing it and when you can try to log in again. Even though this fix is tested for Lume Pad 2 and Nubia Pad 3D, some people have had success following similar steps for logging into apps on legacy devices.

If the above steps work for you, please post here and let us know!


I use Login from the OG-Lume-pad on Lume-Pad 2, do you think I have to log out of the OG-Lume-Pad? And do the same to both pads? With the instructions you layed out above :point_up:t6: fyi I still use both tablets

No, this only affects the device you’re having issues with. Whether you’re logged in or not on other devices doesn’t matter.

Went to have a look at the LeiaPix gallery earlier today and all of a sudden, it wouldn’t display but just kept directing me to the Leia ‘Manage your account’ page and no ability to exit that page.!!! This is on my Nubia Pad 3D. I then checked my original Lume Pad and Red Hydrogen and had no problem accessing the LeiaPix gallery.

I then proceeded to delete the LeiaPix App on my Nubia thinking that maybe a reinstall would help.

After deleting LeiaPix, l went to the App store and it was there l had issues and was unable to Login to the Appstore!

I stumbled upon this resolution posted by Nima re: login issue and followed it exactly.

BINGO … ! It worked.
I was able to log back into the App store and re-download LeiaPix on my Nubia. I now have access to the LeiaPix gallery without a problem.

Thanks Nima!! This solution worked for me!

1 Like

Yes I cannot correctly login on the Nubia Pad 3D.
No problem with the Lumepad 1

Yes I followed the info, all is ok

Im on a desktop how do i resolve this login problem?

I would recommend trying another browser or another device.

If you want to fix the issue in your current browser, try clearing your browser cache.

I followed your instructions and all is good.
Thank yoi

This solution worked for me. I logged in using the LeiaPix app after clearing the system as described after which all other apps worked as well.

Thanks for this @Nima
Was trying to figure it out on my own and did the basic troubleshooting. Never thought CHROME data clear would solve the issue.

Super :ok_hand:

Thank Leia’s incredible QA Team for putting it together. They have a thankless job and do whatever they can to find bugs and fixes for bugs that the engineers breathe to life.

There’s no way we would have figured out how to fix this issue if not for them.

1 Like

Well I appreciate their efforts, as well as yours~

Used to work but now getting the authentication error. Tried solution many times. Doesn’t work. Sent email about this over a month ago as instructed and have received no reply. To say I regret buying this tablet is an understatement. Feels like an unfinished product. How basic is being able to log into the appstore? Mind blowing.

I followed the instructions and all works for me.
The Nubia Pad 3D and the Lumepad 1 are great I wouldn’t sell them