LeiaLoft Store not working

@kurkosdr I’m also unable to login to the store, not sure why though

Maybe it was a temporary issue: just tried in my H1 and everything works fine

Maybe it was a temporary issue: just tried in my H1 and everything works fine

It still doesn’t work for me. Cleared app data and all. What version of LeiaLoft are you using?

You are right… the symptoms are these: I can use Leialoft (even if in the first attempt I always get a message to “retry”) but unable to log in my account (I was using my Google account). @Nima Do you know if there is any new issue? My Leialoft account, including my credit card info, was accessed via my H1 in the past.

We are looking at the issue affecting H1 users that have adopted the new login system on Lume Pad… stay tuned !


Any news?

I am not asking for new apps for the Hydrogen One, but I am afraid of having to factory reset and not being able to re-download any of the Leia apps.

@kurkosdr the team is working on this full time now that LeiaFlix is out, a little more patience we are on it :pray:


While Leia Appstore is no longer supported on the RED Hydrogen One device, Leia Inc. is offering Hydrogen One-compatible builds for nearly a dozen Leia Lightfield apps. Our formal post about it can be found here. You can also click this link to download all final versions now. Thank you for your patience and happy downloading!


What about our purchases on the Leia loft store? I can’t access my account on LLS on my H1, it says “Hmmm they didn’t work please sign in again Try Again” every time I try…

See the Post above yours, the store ist no longer supported for the Red Hydrogen one.