Post processing errors

Hi, I’m trying to get post processing working. Here’s my setup:

Unity 2020.3.34f1
Postprocessing v2 3.0.3 or 3.2.2

I get the following error:

NullReferenceException: Object reference not set to an instance of an object
UnityEngine.Rendering.PostProcessing.PostProcessLayer.BuildCommandBuffers () (at Library/PackageCache/com.unity.postprocessing@3.0.3/PostProcessing/Runtime/PostProcessLayer.cs:532)
UnityEngine.Rendering.PostProcessing.PostProcessLayer.OnPreCull () (at Library/PackageCache/com.unity.postprocessing@3.0.3/PostProcessing/Runtime/PostProcessLayer.cs:466)

Which version of the Unity SDK?

You can see the version in LeiaLoft/Resources/VERSION.txt




I previously worked on the Leia Unity SDK.

I caused this bug that got shipped in Leia Unity SDK 0.6.21. I fixed it at some point after the release of Leia Unity SDK 0.6.21. Hopefully Leia Inc will release an update.

1 Like

Hello Hawken,

We have released 0.6.22 with the fix John mentioned above. This should resolve your issue and unblock your post-processing development. It can be found on our website or the Unity Asset Store.


Thank you for spotting and fixing this issue during your time here and for your continued active engagement in the lightfield community! Hope all is well!



1 Like