Unity SDK 3.2.4 - Unity 2022.3.2f1 - LumePad2

Hi All,
I’m having a problem with the UNITY SDK for LumePad2 (updated to the latest firmware). I’ve tried following both the online tutorials and the example projects, but I can’t seem to get them to work on the pad.

When I use adb to debug the app, the error is clear:

NullReferenceException: Object reference not set to an instance of an object.
Unity : at LeiaUnity.RenderTrackingDevice.Is3DMode () [0x00000]
Unity : at LeiaUnity.RenderTrackingDevice.Update () [0x00000]

NullReferenceException: Object reference not set to an instance of an object.
Unity : at LeiaUnity.RenderTrackingDevice.GetViewingDistanceInMM ()
Unity : at LeiaUnity.LeiaDisplay.RealToVirtualCenterFacePosition (UnityEngine.Vector3 FacePositionMM)
Unity : at LeiaUnity.Head.Update ()

The app is running, in the example project “LeiaLogoCameraCentric” I can use the UI, if the background skybox is present, I can see it, but no models are displayed (I am using the URP pipeline).

It seems that the display is not being recognised, but I’m unsure how to resolve this issue.
Is this a known bug?" Any idea why?

Problem solved.
Solution: always read the release instructions!! I had to update the Leia DisplayConfig and Leia FaceTracking Apps

But which version.

The version cited in the doco does not exist in the store?

Hello @qzzf1w

Can you try the latest Unity SDK (v3.2.5)? You can download it from this link. Please make sure the Leia FaceTracking and Leia DisplayConfig are up-to-date with version 0.8.20. If your FaceTracking and DisplayConfig are not updated yet, you can update them from the Leia Appstore.


3.2.5 is not the latest.
I have 3.2.6 installed.
It is the latest version.
I have 0.8.20 installed for DispllayCOnfig and FaceTracking
Your documentation say 0.8.28 is the latest

Question: When is the lastest you took a fresh machine and tried a setup from your own instructions. I think if you did that, you would better understand the instability of your code base, your instructions and perhaps you could get to root cause.

None of this is working for me.


For Lumepad2, version 3.2.5 is the latest for the Unity Plugin for LP2, and version 0.8.20 is the latest for display configuration and face tracking. I tried setting it up from a fresh machine and generating the build for LP2, and it worked correctly. Could you please try one more time with the SDK link I provided above and generate the build?

It is working.

But if you follow the documented instructions it doesn’t;

You should update your instructions

Also there are several bugs;

Clicking download new latest hangs
The spinner in the bottom right never stops
And the WIndows code misteriously gets added to the android build and corrupts everything

Other than that it works.