Leia Link still broken since 2022

This is my second Pad 2. I sent the first one back and then saw an upgrade came out. So I made a new purchase bIsecause the price dropped to 649. An awesome deal for a tablet like this. IF it works though, and all is not working. The leia link has not worked at all and I am getting the same error message people were getting in 2022 about unable to download link. Is this now working for everyone or is everyone tired of complaining? I have tech support working on this and will eventually delete all of my files to see if that works. If not, I will have to return this tablet as well, and I really love most of the things it does.

Hey @Jerrycleveland,

Issues with LeiaLink are due to unsupported files being uploaded, like SBS or MPO.

We’ve fixed this bug, but it isn’t released yet. Most users have had no issues with LeiaLink, and we’re happy to clear their storage in LeiaLink to fish the problem out.

Let us know if you still have issues after we flush your account to fix the clog.

Thanks for the reply