LeiaPix pictures, some not opening, any one else getting this problem on the original LumePad

Hi still getting the problem in LeiaPix when using the original Lumepad some pictures will not load, you get the thumb nail, tap on it, it does not open just getting a rotating circle, but the same picture will open on the new device.
This can happen even if you are looking through one users pictures, all open except one picture.
Also in the morning 21/5/2023 I opened pictures from Diamondave B, on the original Lumepad, with no problem, but this evening not one of the user photos will open, just got the loading circle, they did open on the new device.
This problem has been happening for some time. Please fix this bug. I use the original Lumepad alot, it is a great device.Checked today 22/5/20223 still the same with user Diamondave B not one of the picture open from the thumb nail just get loading circle, can open many other users pictures, please help to resolve this problem
Checked to day 23/5/2023 still the same can load all new posts from thumb nail on original Lumepad, but Diamondave B all thumb nails are there in 3D but will not load just get rotating loading circle
Checked today 24/05/2023 the content on Diamondave B, the latest pictures loaded from 3D thumb nails, but the content from 3 day’s ago would still not load.
This looks like a server problem.
Please can someone give an update as it has been happening for some time

1 Like

I tried to login to LeiaPix today on my original Lume pad and it takes me to a screen that says “503 service temporarily unavailable”. Notice someone else said an issue as well. Is there a guesstimate as to a date this will be fixed by?


Having the same problem as well on the original Lume Pad.

1 Like

Hi sorry have not had an update. May I suggest you contact Leia support and report the problem.

Hi I just checked to day 25/5/2023, still the same problems.
I checked out Diamondave B posts, I all yesterday posts one except one open from the thumb nail , all posts from four days ago will not open from the thumb nail, what is so odd, the day he posted them they did open but not now.
I also find some posts from other users, some of there pictures do not open, but you always get the thumb nail
I feel this is server/network problem.
Hope Leia is listening and sort this problem out soon it has been going on along time.
Please can some in Leia respond to this problem so we know why this is happening and how it will be resolved