Not all pix load for me

Some of pix I try to open will open. Anyone else having this issue? It’s been happening for a few months or so

1 Like

Same for me. The pictures are actually downloaded, they appear in the thumbnail views and I can export them but they aren’t rendered as full picture. It either stays black or shows the purple circle.

1 Like

Yes I am finding some LeiaPix do not won’t to open, but the thumbnail is there

Yes, this happens to me too.

I think it is because there is a format used by those specific images that only works with the Lume Pad 2, not the original lume pad. Anything you see that they have generated using Leia Dream isn’t loading or visible for Lume Pad 1 users. It is also possible that some of those images may actually be in motion, which is something that isn’t supported by the Lume Pad on LeiaPix


This is an unexpected bug and the team is investigating now.


Just tried it and some pictures will not load, get thumb nail, tap on the picture just get rotating circle

Tried Leia pix this morning still some pictures only show thumb nail and will not load picture, hanging on rotating circle. Can we have an option in report that can be ticked to say the picture will not load, then Leia will be able to see the problem. Tried again to day under nature, still the same problem with some pictures

1 Like

Some pictures are still not loading. There are some great nature thumb nail pic, but I cannot load the. Can the report option have a tick box cannot load picture, tested today 28/3/2023 still some pictures will not load. You can look at a user and most pictures load, but one or two do not, any update please

As mentioned above, this is a known issue and the team is working on a solution.


Hi I have just tried pictures that did not open before, they are now opening. Thank you for the fix. All the best Roger Burley

Hi problem back again, went to newest, taped on two thumb nails pictures, did not load just got rotating circle

1 Like

I have the LP1 and LP2. Some of the images created on LeiaDream do not show up as described in the thread. Although, some do. Has anyone found a solution. In the next day or two I am going to try to save on in another format and upload it to see what happens.