LeiaPlayer 2.11 released to beta (new share feature!)

Happy Lumepad day :slight_smile:

We’re excited to be adding a new animation share feature to LeiaPlayer. Download beta and hit the “share” button to try it, and be sure to share your best animations!


Strange. I did not get the notification for this latest beta. To be sure I have opted out and then again opt in in the beta program, but still did not get the usual notification about the new release. I have tried to clean cache but nothing. Should I clean also app data?

1 Like

Have you tried closing the application entirely, then re-opening the application?

(Update: Have noticed that I have also been unable to download the new Beta.).

1 Like

Sure, I did it: closed app, cleaned cache and reopened app.


I’ve tried these too, with no update notification.

1 Like

Thanks folks, we’re investigating!

In the meantime, you can bypass the in-app update and download the new version here: https://install.appcenter.ms/orgs/leia-inc/apps/red-player/distribution_groups/all-users-of-red-player


Downloaded and testing: really nice :slightly_smiling_face:. Powerful! Sometimes there are artifacts and in the case of GIF colors have limitations (so I’m using animation) but it is amazing. This way I was able to share a nice light effect that so far was impossible to share (in 2D looked just as a picture with bad exposure, while in 3D you can see the sun rays; with animation I can show at least what I meant). Loop effect in animation too could help

1 Like

Thanks for the feedback Marco!

We are working on the artifacts, and plan to have an improved version around November 2nd.

Loop effect- There is an issue with the loop being broken for gifs. We plan on having the fix out for this later today.


I noticed in the last couple of beta drops that editing the focus and depth is not quite WYSIWYG. This leads to overcranking the final adjustments. Anyone else experience the same?

I noticed this once while editing a series of photos yesterday, the final picture was quite “jumping” but I thought it might have been either a user error or due to the fisheye lenses used for the photos. Now thinking about it, maybe it was due to moving the depth and focus sliders to the extremes while playing with it. But before saving, the sliders were back at middle values, nevertheless the picture looked like having the extreme depth set.
A while ago, I saw a similar behavior with the color pop slider: once the slider was moved up, it didn’t bring back any color even after setting it down to zero, had to discard the edit completely.

Just tried it again but cannot repro with only the sliders up to 100% and/or 0%, and then back to middle before saving, so there is probably more involved than just that. Another observation: sometimes it leaves edit mode after a few seconds of moving sliders and then pausing.

It appears to be more noticeable depending on the type of image. I have a shot of a bunch of pumpkins that I recently posted. When I adjust the depth slider and tap the checkmark, you can see the image shift as the changes are committed.

It seems that such advanced share feature does not yet work for pictures obtained by 4 images: am I correct?

That’s correct. It currently supports images created by the camera, or generated from the 2D-to-3D conversion feature, but not 2x2 images.

1 Like

How about icon thumbnail to see different formats of h4v, h4v pro, h4v quad while swiping tru gallery mode mode?

As it always was with Red Player?

Now they still have all the same icon thumbnails and there for it is not usable to me as i whant to see different formats of h4v pics while scrolling tru my pics, and convert back to latest Red Player

1 Like

Thanks for the feedback @Chillerfpv, we’ll take that into consideration for future versions.


4V/ST/2D View Mode Select UI change from 2.11 to 2.12 is exactly what i wanted.

Great job addressing my request before i made it, & on releasing a fantastic & continually improving product!