LeiaPlayer will not update

Tapping the update button does not update Leia Player

1 Like

I have the Nubia Pad 3D and have the same problem

Yep, I’m having the same issue. If i click update nothing happens. If i click it again, it says it is being downloaded. The “Update” button eventually changes to “Open” but it isn’t actually updated. The next time you go back into the Library on the LeiaStore, it still shows as update available.

1 Like

Yes exactly the same for me

Whilst the official solution to this problem has not been communicated nor released yet, has anybody tried clearing storage on their Leia Appstore application? This may or may not resolve the issue, but it’s worth a shot:

  1. Close Leia Appstore (press Android Square button and swipe up)
  2. Long Press Leia Appstore icon
  3. Hit “App Info”
  4. Hit “Storage and Cache”
  5. Hit “Clear Storage”
  6. Open Leia Appstore
  7. Attempt to re-download the update.

I’ve noticed on Android sometimes old data can end up in app cache or storage. It might be worth a shot.

Carry on, fellow enthusiasts.


This is good advice, and will in many cases resolve the issue. Because it doesn’t resolve every known issue, we recommend reaching out to help@leiainc.com

1 Like

I did this on Friday and today, but still the same problem.
I also send support a message on Friday on my pc email account and got an automated response and case number, that I would be contacted as soon as possible, but up to this time have not received a response.
I will report the problem again today on my phone Gmail account.
Hopping soon the problem will be resolved

Ok, so

  1. stopping Leia face tracking
  2. disabling both Leia app store, and Leia player
  3. clearing both Leia app store, and Leia player
  4. enabling both Leia app store, and Leia player
  5. then you can update Leia player
  6. finally restarting Leia face tracking

This sequence worked for. Perhaps face tracking is causing issues as I didn’t try updating Leia player just stopping face tracking by itself. Just an idea

Thank you

Sorry still the same, keep getting the update tab
Still no response from support.

I am going to try it again later today as I may have missed something.
Still no response from support just like to know they are looking at the problem

Just got the update to Leiaplayer to down load
Go to Leia Appstore clear storage and cache.
The update will now install.
Better than that Skate_wheels. Jpg works and even better my MPO file open correctly
Great work Leia

1 Like

We’re looking at the problem.

1 Like

Thank you for your response.
It is great to be able to view my MPO pictures again.
The MPO pictures look great on this amazing new screen.
Many thanks for this first update.

For those still having issues, you need to clear storage for both the store AND the player, then update.
Or at least that worked for me.
Also fixed issues I had with other apps that did not want to download.

1 Like