Lume can't connect to hidden SSID Wi-Fi

So I tried to connect to a Wi-Fi with hidden SSID and the tablet isn’t able to connect. All other of my devices can without any hassle.

@Kano3D Can you tell us more information about the access point (model) and it’s Wifi configuration, e.g. versions of Wifi supported, versions of Wifi activated, and frequencies(2.4Ghz and 5Ghz) supported and activated?

Hidden networks shouldn’t be an issue for Lume Pad.

Huawei Flybox 4G B593s.
WPA2 key. 2,4Ghz

Hey @Kano3D,

Try the following:

Go to

Settings > Network & Internet > Wifi > Add network > Input SSID name > Change hidden network to Yes

Let us know if that works.