LumePad 2: Can't access files manually

Hi! I just got my Lume Pad 2 devkit and I’m so stoked!

I tried manually plugging in the Lume Pad with my PC but haven’t been able to access the tablet’s files.

  • When I plug in, I hear Windows 11 make a sound signaling connection
  • Lume Pad has popup with options to “Use USB for”: Charge only, Install driver, Media device MTP, Camera PTP
  • (No option for File Transfer that I’ve seen some folks mention in previous forum posts)
  • I tried installing driver to Win11? Not sure if that did anything
  • I’ve tried rebooting Lume Pad 2, plugging it into other USB C ports. I’m using the wire provided.

My goal is to manually drop my 3D models from PC to the tablet. I do a LOT of 3D model + XR iterations so wired transferring is much more preferred than Cloud transferring.

Any help you can offer would be so helpful! I want to see my models on the tablet to finish up my Lume Pad 2 unboxing + demo video ;))



Hey @estellatse! Please select “Media device MTP” and you should see it appear.

Can’t wait to see what you do with it! And also you can load up VR180/360 videos into LeiaPlayer if you have any :slight_smile:


Thanks so much, Nima!
Hmmmm… I’ll try that again – I tried that option yesterday and didn’t see it appear. I’ll try the rebooting game and USB slot roulette once more. Will report back later today! :slight_smile:

1 Like

I just got my Lume Pad 2! But I’m having a similar USB problem as what Estella is reporting.

I’m using Windows 10, with a USB3 connection. On my PC, I can see that both the internal storage and my SD media are successfully shown. However when I try to open either of these on my PC, the PC window usually closes immediately, and the Lume 3 makes a “ding-ding” alert sound. Sometimes I can successfully open either the internal storage and my SD media, and then I can sometimes create a new folder. But even after many tries, I have not been able to successfully write a .mpo file from the PC into the Lume 3. Sometimes there is an error message on the PC, that the device closed unexpectedly.

Very disappointing, but I understand that the Lume 2 is band new, so I suppose a few problems should be expected.

David V

Hey @DV3D, have you tried using a different USB-C cable?

And are you selecting the proper setting in the pop-up window on your Lume Pad 2 before trying to manipulate the files on the PC?

If this still persists with different USB-C cables you try and are following the proper procedure, please reach out to for support.

Wow, that was an easy fix, just use a different USB3 cable, thanks Nima!

So now I can successfully write .mpo files onto the SD media in the Lume 2. But I don’t see how to use LeiaPlayer to open these files directly within the app. LeiaPlayer apparently can only open files from the Lume 3 internal storage, not from the SD media.

I am able to use the Android “Files” app to manually find and open the .mpo files on the SD media, but apparently I have to open each file individually to view the photos. Any ideas for a fix for this problem?

David V

We’ve been aware of this need and have been working on it for a while now, but it’s actually pretty complicated to ensure we can get all the features in LeiaPlayer working with external storage media (both MicroSD and USB-C storage devices).

That said, it’s literally the top priority of the LeiaPlayer Team, and while I don’t want to make any promises, it should definitely come out in the next update or two within a couple of months.

1 Like

OK, thanks for the honest explanation. I understand that probably not everything will be perfect, at the initial release of any complex new tech.

1 Like

Hi @estellatse! To Nima’s point, you may want to upgrade to a USB-C 3 cable. I had a similar issue using an older USB-C cable. It could be you just need to switch out the cable. Keep us posted!

1 Like

It takes several seconds to set up things to work, but that MTP selection then works similar to original Lume Pad.

1 Like

@Nima Viewing files directly from the SD card in leia player would extremely helpful. There is a much bigger issue that I am having at least with my Nubia Pad 3D. I can move/copy files from the SD card to internal storage just fine, but moving or copying files from internal storage to the SD card does not work. I need to free up space in the internal storage, but can’t move or copy any files to the SD card (tried it with 3 different micro sd cards and all failed, even with a single file). It says 15/15 files failed to move/copy. Is this an issue that has been identified by the team? I have tried using the google file app and the files app to do this and neither one works. My micro SD cards work just fine with other devices.

@Josh_G I haven’t had this issue in the past, but we’ll check if we can reproduce the issue with the current firmware and the MicroSD cards we have.

I’ll have the QA Team take a look, but I just tried, and was able to move files to the MicroSD card without any issues. Did you format the MicroSD card in the Lume Pad 2? If not, the Android OS may be able to READ files FROM the MicroSD card filesystem, but won’t be able to WRITE to the MicroSD card because it’s not a fully supported file format. Either way, Lume Pad 2 supports all the default file systems that Android does.

I formatted all 3. The same issue happens for all of them. I can’t copy any files over. The formatting says its finished and ready to copy media to the SD card, but when I try to do it, I get an error saying 7/7 files failed to transfer. The SD cards I am using are Sandisk Extreme 252 GB, micro SD V30 XC1, A2 purchased on Amazon. What do you recommend in this situation? It sounds like it should be able to copy or move photos and media files from internal storage to the micro SD cards.

The SD Card works fine for me. I’m able to copy files and everything. I’m using this one.

1 Like

Thanks for this. As I mentioned in our LeiaChat, my Lume 2 isn’t recognizing mine…which happens to be a new SanDisk Ultra microSDXC UHS-1 256GB, A1 (from Amazon). which works on another (W10) netbook ok. I get a “Issue with SanDisk SD card…tap to fix” which takes me to How will us use this SD card?..Use as portable storage, with a Format button on bottom which doesn’t seem to actuate. I did get a “corrupted” message at one time, but hasn’t come up lately.

But the Lume 2 does recognize an older, (W10) SanDisk 32GB SD. I’m up to date on system and apps. I’ll order a new SD.

DUH! Problem solved. Somehow, perhaps from the manufacture, the microSD card was formatted in exFAT, and the L2 didn’t like that. I just reformatted the microSD, on my W10 pc, to NTFS, and the microSD now recognized by the Lume 2. So correct me if I was wrong, but seems like Lume 2 is looking for NTFS format in the larger microsSD card. And now, I’m guessing, the the Lume 2 didn’t recognize the exFAT card at all so Format (button) didn’t do anything.

I’m having the same issue I have a 1tb SD card cant movies movies from internal to SD always says failed

Thanks I did the same had to format it on my PC and not my lume pad and it worked

1 Like

Oh yeah. I mentioned that on the call. I’ve had that issue with Linux and Android before, which is why I typically format on my PC first (in Ubuntu) as that works more reliably than on mobile. I guess technically exFAT is better for Windows PCs, but it seems like a strange choice to come pre-installed. You can read more about this issue here:

1 Like