Download files from pc to lume pad

Please advise how to download files (pictures and videos) from PC to the Pad and how to play them in 2D and 3D. Unfortunately the manual
does not address these basic functions. Thank you.

Hey @valepstein,

The Lume Pad works as a normal Android device, so it will work the same way all Android devices do.

The Lume Pad Guide does mention how to do it for images here, but it will work for all files:

If you have a Mac, you’ll need to use an app called “Android File Transfer” that you can download from Google online.

If you’re using Windows, simply plug your Lume Pad into your computer. Then, a pop-up will appear on your Lume Pad asking what you’d like to do. You must select “Transfer Files”. Then your Lume Pad will appear in the left hand bar of your Windows File Explorer and you’ll be able to move files on and off of it just like it was a flash drive.

Let me know if you have any other questions!

Hi Nima!
Thank you for answering my email! I’ve just bought this tablet and got very confused trying
to use it. I have the other Android tablet and never had these problems.
I have a Windows PC and always used the USB cable for transferring files from it to the tablet.
This time when I use your Lume Pad I can’t get my File Explorer to recognize it and show it in the left
hand bar with all other drives. When I’m disconnecting Lume Pad asking for a permission to
disconnect I see that the USB device # SDM845-QRD_SN:9A43E9F3 is actually connected to the
PC but it is not shown on the left hand bar (picture is attached).
On the Settings page in Lume Pad in Storage section in Connected Devices on the right panel it
says: Currently connected: USB File transfer.
I have a second question. The brochure for Lume Pad and ad on Amazon show that the total
memory this tablet has is 128 GB. But only 16 GB is shown on the manual for this tablet. Both pictures are
attached. Is the manual outdated?
Please advise me on file transfer and on memory size.
Thank you very much,
Valentine

Is that a fake Lume Pad?

Hey @valepstein, Lume Pad absolutely has 128GB of internal storage. I am unable to find the picture you’re showing in the manual. Here is a link to the newest version of the Lume Pad Manual: Manual

While we’re at it, here’s a link to the Lume Pad Guide, which should provide even more information about specifics on how to use it: Lume Pad - Lume Pad

I have the other Android tablet and never had these problems.
I have a Windows PC and always used the USB cable for transferring files from it to the tablet.
This time when I use your Lume Pad I can’t get my File Explorer to recognize it and show it in the left
hand bar with all other drives.

How do your other Android devices work? The process should be the same.

Are you seeing the pop-up appear on your Lume Pad? It should say “Use USB for” with multiple options, with one saying “File Transfer”. This should appear automatically when your plug your Lume Pad into a computer while it’s on.

If that’s not working, you may need to enable USB debugging on your Lume Pad first.

Also, make sure your Lume Pad is fully updated. Usually it should show “LUME_UI_1.3.37_LPD10_RoW” as your OS version.

Hi Nima,
Thank you for your response. I’ve checked the storage on my Lume Pad and
it looks like it has 128 GB. Probably the memory was increased with the Pad
modifications. Previous manual indicated 16 GB (PDF attached) on the “Settings”
page in “Storage” and the latest one does not show the memory at all (PDF attached).
I have also checked if my Pad has been updated. It is updated - the OS has exactly
the numbers you mentioned in your email and the message indicated that the Pad
has been updated. This means that the only way to make connection of the Pad
with the PC possible is to enable USB debugging first as you recommended.
Please advise me how to do it, I could not find it in the manual.
Thank you very much,
Valentine

(Attachment LUME PAD NEW MANUAL.pdf is missing)

(Attachment LUME PAD OLD MANUAL.pdf is missing)

The link to the previous manual was stripped when you emailed the response. Can you please try from the Forum site, or alternatively, just let me know where you got the old manual from?

This generally should not be required, and if you’d like we can try a few other things, such as restarting your Lume Pad and your computer before trying again. In addition, you haven’t mentioned yet whether plugging in your Lume Pad shows the message I mentioned above. It’s possible that you’re using a cable or adapter that doesn’t support USB data and instead only supports charging. Do you have any other USB cables nearby that you can try?

If all else fails, you can enable USB debugging and see if that resolves it by following these steps: Configure on-device developer options  |  Android Developers

I used the cable provided in your package. I’ve restarted the Pad and the PC. I 've unlocked the Pad.
I’ve connected the USB cable to the Pad and the PC. In a second I got a dialog on the Pad “Use USB for:”.
I’ve pressed on “File Transfer”. In a second a message appeared in the right hand bottom corner of the screen
of my PC. I’m attaching the screenshot showing this message and the left hand panel in the File Explorer.
The message was useless - I could do nothing with it, it lasted 1 second and did not react to a single
or double click. Nothing appeared in the left hand panel. When I was disconnecting the USB I was getting
another message in the right hand bottom corner of the monitor, the screenshot of it I’m also attaching.
I’ve also tried to enable USB debugging but after I got to “Developer Mode” there was no way to
enable USB debugging. Nothing matched the instructions. Maybe because instructions were written for
the phones and not for this Pad.
Please advise. Also do you have live support so I could get help from a person over the phone?
Otherwise I think that the Pad I received is a defective one and I will have to ask you for replacement
or to give me directions for return.
Thank you,
Valentine.

Android is the same software underneath, so it’s the same for Lume Pad as well as all other Android devices. As mentioned in the link I sent, these are the steps for Developer Mode:

  1. Go to “About Tablet” in the Settings app left hand bar.
  2. Scroll down to “Build number”. Tap on the build number 7 times.
  3. Go to “System” in the Settings app left hand bar.
  4. Scroll down to “Developer options” and tap on it.
  5. Scroll down to “USB debugging” (under the “Debugging” section) and turn it on.

I think it’s more likely that your PC or Windows 11 installation is having issues mounting an Android file system in Explorer because it shows up properly as a connected USB device within Windows. But we do have support you can always reach out to at help@leiainc.com and if your Lume Pad is indeed defective we’d be more than happy to replace it.

Hi Nima,
Thank you for your advice. I proceeded with the Developer Mode and turned the “USB debugging”
on. I restarted the Pad after this and tried to connect the PC again. This time after “File Transfer”
was selected the monitor did not even show the notification that the device was connected in the
right bottom corner, nothing appeared in the left hand panel. Only when I was disconnecting the
USB the message appeared that the device can be safely disconnected.
Please advise what can be done now.
Thank you very much,
Valentine

I would say there are probably a few things you could still do, but only if you want to:

  1. Try a different cable
  2. Try a different PC
  3. Try to reboot the PC and Lume Pad and try a few more times

Or, just reach out to help@leiainc.com and they will take care of you. If their more advanced troubleshooting steps don’t help, I’m sure they’ll help you replace your Lume Pad.

Thank you, Nima. Should I undo the USB debugging?

It generally doesn’t matter, but for maximum security yes, you should disable USB debugging if you’re not actively using it.

Nima, please help! I’ve returned my first Lume pad because I could not connect it to
my Windows 11 PC. Now I’ve got a new one and I have exactly the same problem!
When I’m connecting the Pad to the PC the Pad shows that it’s “currently connected”,
“USB controlled by this device” and “use USB for File Transfer”. When I’m disconnecting
the Pad from the PC the USB connection dialog in the PC confirms the connection but
nevertheless it does not appear in the File Explorer. My PC is only 6 months old and
works as a new one - no problems. What is the problem now?
Thank you,
Valentine
in File Explorer as a new drive.

I’m not sure. You mentioned you have another Android tablet. Have you tried to use it with your PC and if so, does it work? Can you transfer files to it?

What model is it and what Android version? That might help us understand if it has any drivers or something that are conflicting with Lume Pad.

Hi Nima! Thank you for answering my email. I have just managed to transfer a file
direct USB connection. Both ways work fine. The Lume Pad is not recognized by
the PC and bluetooth connection does not work because of the PIN code problem.
My other pad is KingPad K-10 with Android version 10, supposed to work similar
to Lume Pad. I tried to use a USB drive for file transfer but even after the drive was
recognized by Lume Pad and the file was selected for transmission the pad did not
give me the option to proceed. Please advise.
Thank you,
Valentine