Lume Pad 2 OS Upgrade: LumeUI Version 1.0.48

Hi these are the two updates to the Nubia Pad 3D and and their history information and the File Manager was included with the 04 update.
It does not look like the Leia system update has been sent out at this time

Update:

I just checked again and now I was able to login back.

LeiaPix converter is also back online. :slight_smile:

Thanks Leia for the fix!

Roger, I agree, Nubia Pad 3D is great. Just wish there would be less scares. :wink:

1 Like

Hi yes both original Lumepad and Nubia Pad 3D are logged in again.
Thanks Leia for the fast response to the problem

C. J you take great picture, I look forward to seeing them

1 Like

Thank you, Roger! I appreciate your feedback. I like your 3D pictures too.
Kind regards.

1 Like

We don’t. It’s ZTE’s device and they’re in charge of testing. However, so far, there have been literally zero software differences in how apps behave between the two devices. They are 99% similar hardware wise (only difference is logos on the rear chassis and a SKU with more storage and RAM on the ZTE side) and the software is 95% similar with minor differences like logo and color changes and maybe some slight alterations in Home Screen layout and preloaded content. All apps should be 100% intercompatible.

1 Like

Thank you very much for beeing so helpful and give very full reply to questions asked.

It could be helpful if Leia obtain a Nubia Pad 3D so Leia can monitor the update progress.

Also to have the Nubia tab 3D on hand to assist in answering question asked by users of the Nubia Pad 3D

Thank you again for responding

ZTE have just messaged me saying awaiting for your feed back.

I said had not had any feed back.

I sent them the screen shot of the Lumepad 2 update info and asked them again when this update would be applied to the Nubia Pad 3D

So still waiting for an answer if and when the Nubia Pad 3D will get the Lumepad 2 update

If you guys have the File Manager app on your device, you have the update. There is no other update.

Hi this was the response I got from ZTE after I sent them the screenshot of the latest update to the Lumepad 2

October 25 2023 - Leia Lume Pad 2 Update 1.0.48 - Everything 3D is Broken

A few days ago I used the LP2 to show some friends. When I opened a few apps, the 3D was acting up and not working, until I hit 2D and then 3D and it would work again. Cyberpunk city model worked. LeiaPix 3D photo worked. YouTube to LeiaTube 3D worked. I think maybe some 3D in other apps like Mozaik didn’t work.

Now today, I open all the apps and everything is broken.

So I searched about a broken update and found this forum.

To my surprise this is an older update from months ago and nobody has commented on this yet so I figured I should let you guys know something is going on. Hopefully I’m just an outlier. Others comment if you have these problems too and ended up here.

Here are the details:

System Update:
1.0.48 “Your Software is up to date.”

All apps appear to be up to date.

Apps / symptoms:

LeiaCam:
Live image view is black
After taking a photo I can see thumbnail
Version 2.1.04958

LeiaPix:
Instant crash + pop up “LeiaPix keeps stopping”
Version 3.0.21011

LeiaChat:
2D preview works
3D preview is black
Version 1.2.140

LeiaFlix:
2D trailers work
I’m not going to rent broken 3D to test. (An option to buy movies would be cool.)
Version 2.1.188

LeiaTube:
Thumbnails visible
Videos are black
YouTube to LeiaTube also black
Sound works
Version 2.1.10

LeiaPlayer:
Thumbnails visible
Videos are black
Sound works
In Camera Roll: Thumbnails visible,
When opened, 2D & 3D shows black
Version 4.3.41785

LeiaFrame:
Thumbnail visible
Black when slideshow starts
Version 2.1.5

LeiaDream:
2D visible
3D black
Version 1.1.8

LeiaViewer:
Thumbnails visible
When opened, (with enough light) (Tested with cyberpunk city and tree, both previously worked)
Background wallpaper and model are shrunken
No 3D effect
Model does adjust to head movement
When zoomed in, model expands past shrunken background with warped effect, edges of model disappear towards the viewer, showing interior of model
Version 2.1.2

Leia Appstore:
No obvious problems
Version 2.2.672

Other apps:

Mozaik3D:
“3D” now looks 2D
Head/tablet movement doesn’t seem to adjust models
Version 2.0.433

Dungeon:
(Plenty of light)
General head motion tracking works sometimes
Precise eye tracking/projection is broken
Both eyes can see both virtual camera perspectives on the screen at once, nearly 50/50 opacity
No 3D effect, just 2D ghosting
When tested at a distance, images seemed to converge more, closer to a 3D effect
Sometimes intro scene becomes warped down and to the side, and 2D, and then plays at an even more extreme angle with poor resolution and no head tracking adjustment. Can still move character while broken like this
Version 0.1.0

CyberCop:
3D effect broken, ghosting overlap
Head tracking works
Version 0.2.0

Other apps:
No 3D effect

Yikes. Please let me know what I can do to fix. I’ve already restarted device multiple times. Factory reset? Would be unfortunate to lose data. Are you guys aware of / working on fixing these problems? Please get back asap, thanks.

Make sure you’re logged in to Leia AppStore and you’ve installed the updates for Leia DisplayConfig, Leia FaceTracking, and Leia MediaService. And ensure the camera permissions are enabled for the Leia apps and required services.

If that doesn’t fix the problem, reach out to help@leiainc.com

Can confirm.
For some unknown reason I had precisely the same issues as you described in detail.
Factory reset solved it for me, problems didn’t come back since then.

1 Like

Thanks. Yeah, all of that was already done, besides some apps did not have camera permissions, which is weird because they used to work and so must have had permissions before… right? The ones that had no camera permissions randomly were dream, pix, tube, viewer, cop, and more 2D apps that shouldn’t need it.

But, I did all the same tests after giving camera permissions during use and got the same broken results. So I’ll message help later.

What bothers me though now that I think of it is the phrasing of the permission: “Apps with this permission can take pictures and record video”. What does that mean exactly? Can the owners of the app take photos and videos with any camera at any time without me knowing? And view and store them? If so, then I’m out.

If not, then it should be rephrased and made clear there is nobody on the other side spying on you and no possibility for your private data to be leaked to the owners of the app. It should say “Apps with this permission will be allowed to allow you to privately and locally take pictures and video, with no viewing or storage access of your data.” or “Video streams will only be used live for tracking and not stored.” Something in depth like that I think is fair enough when talking about vague access to cameras, “taking” and “recording”. All companies should do this better, not just you guys. No explanation is just suspicious. Let me know what the deal is about this. Thanks.

In theory, yes, while the app is running (not when it’s closed). In practice, no. We don’t store image data in the vast majority of our apps except for LeiaCam for obvious reasons.

We can’t. That’s how Android works. There’s no possibility to change it, nor should there be. For user’s safety, it’s important that they’re aware of what giving camera permission to an app does.

I don’t understand why the creators of apps need to be able to access the cameras themselves. Couldn’t apps just do their thing locally without sending any info or access to the app owner and be just as functional? Shouldn’t users have the option of privacy? I don’t want to have to worry about some creep app owner with less morals than Leia spying on my girlfriend getting out of the shower while I use his app. Why should this invasion of privacy just be accepted? I don’t agree.

Well, it’s all or nothing. Either your camera can be used, or it can’t. There’s no way to tell apps they can only use it for Leia FaceTracking but not anything else.

This is exactly how it works. As far as we know (and we do test it) no 1st party or 3rd party app on the Leia AppStore (besides LeiaCam and LeiaChat) stores OR sends any of the image data to a remote location. And obviously LeiaCam stores it so users can use it and LeiaChat sends it encrypted only to the other participant. The green notification from Android just communicates that that’s a possibility.

Then don’t use any app whose developer you don’t trust. This is true for any app on any OS that requests camera or other permission access, not just those on Lume Pad 2.

Hello - My lumepad still shows LUME UI_1.0.38_LPD20_US_001_0112. When I go to the system update, it checks for updates and then says ‘Your software is up to date’. How can I download the latest update?

I’m in the same boat. 256 GB model. Were you able to resolve this?

Not so far, still waiting to hear from Lume over this.