New Lume Pad 2 broken Play Store

I just got my Lume Pad 2 today in the mail and have been using it for a few hours, but the play store won’t load. I tried disabling the app. I tried restarting. I tried clearing all the apps data. Idk what to do. Please help.

I got this from Google:

Try the steps below to fix problems with Google Play. They may help if:

  • You can’t download or install apps or games from the Google Play Store

  • You can’t download music, movies, TV shows, or other content from Google Play

  • The Google Play Store app won’t open or load, or crashes after it opens

  • Downloads & app updates get stuck and won’t finish

Step 1: Check that you have a strong Wi-Fi or mobile data connection.

First, make sure you have a strong internet connection. It’s best if you can connect to a Wi-Fi network. If you don’t have access to Wi-Fi, make sure you have a strong mobile data connection. Then try your download again.

Get more help with connection problems on Android devices.

Step 2: Clear the cache & data of the Play Store

This gives the app a fresh start and can help fix issues.

  1. Open your device’s Settings app .

  2. Tap Apps & notifications See all apps.

  3. Scroll down and tap Google Play Store .

  4. Tap Storage Clear Cache.

  5. Next, tap Clear data.

  6. Re-open the Play Store & try your download again.

Step 3: Restart your device

If you still can’t download after you clear the cache & data of the Play Store, restart your device.

  1. Press and hold the Power button until the menu pops up.

  2. Tap Power off or Restart if that is an option.

  3. If needed, press and hold the Power button until your device turns on again.

If you’re still having trouble, see other troubleshooting steps.

1 Like

This might help:

1 Like

Sadly I’ve tried all that. I guess I’ll just have to reset the whole device. Idk. Thank you!!!

Ended up remembering you can uninstall app updates by using the … in the app info in the settings app. Did that and restarted. Then updated it and everything worked. I guess the update didn’t install right or something. Yay I’m so happy ot works.