Nubia leiaplayer crashes when playing video or editing photos

I just got my Nubia 3D pad on Saturday I can’t figure it out but my Leah player keeps crashing and I try to play a video it’ll play one second then completely shut down… Also when I take a photo with my Leiacam then try to edit it as I did with my LUMEPAD 1 it goes into a editing page which is different but then shuts down and also crashes… I will say as a proud lover of my original LUMEPAD 1 loved it and still love it so much… I now have the newer pad and I like plenty of the new features that I did not have on my original LUMEPAD however I have crashes and I don’t know what to do? can anyone help?c

Hey James,

Is your Nubia Pad 3D fully updated with the newest OS version? Are all the Leia services updated? And is LeiaPlayer fully updated?

Do you have these same issues with the built-in photos and videos that come with the Nubia Pad 3D, or only with the ones you put on the device?

Please reach out to ZTE for support on Nubia Pad 3D.

Thank you for the quick response Nima I know you all are very busy …let me explain …Camera works and takes photos and videos … the leiatube works “awesome by the way” compared to the lumepad 1 version, I also love the moonlight and that works as well the only thing is my LeiaPlayer it plays a 1 sec of video in 3d then crashes also when I try to edit a photo after clicking on the photo in leiacam it will go to a edit screen then crash as well … I love to send my photos to LeiaPix Im the one who always says “drinking with my lumpad, tada” lol I do love my lumepad more than you know … I am hooked … and even if my Nubia will never hav LeiaPlayer working I will never give it up I love it too much already … I know that Leia products are different than everyone else and offers things that no other tablet offers and when I read complaints, I just wanna scream and tell the person “give your lumepad to a home or person who will love it like I do” these are extremely, deluxe and unique products ahead of theyre time and like no other … so even if my Nuvia wont play in LeiaPlayer, I will love it regardless … I just curious if anyone has had same problem … Ive read almost every post in here and haven’t read anything similar … thank you Nima for your response … you all have a customer for life and that is ME …

I forgot to mention that the built in photos and videos that cam with it wont load at all … I see them in the camera row but when I try to open the the player will say error …also everything says “I have current version”?

I have a Nubia Pad 3D all is ok, not having a problem as you described.
Yes the Lumepad 1 is incredible, but I wish someone would fix the problem of some pictures not loading in LeiaPix as this has been going on a long time

Nima. You mentioned the installed apps and installed media ? No I’m unable to play this installed media and I’m thinking my apps are up to date but I remove them all and reinstall them being that when I got my Nubia ZTE I did the Google update from my lumepadd 1? and maybe it somehow brought the apps over or messed them up but they appear to be the newer versions so I started from the beginning freshly and I still have the problem. I have Giant Question Marks floating around my head and I’m pretty smart with this kinda stuff … My guess which I’m not sure is accurate would be the I somehow integrated my old apps for my LUMEPAD 1 over to my Nubia and somehow that’s causing the glitch do you think that might be the case ?

so nobody knows what to do ? and how do I contact zte ? whats the number or website for this kind of issue because it seems they have many devices

Hi have the Nubia tab 3D and the Lumepad 1. I have updated both ok.
Have you tried a Factory reset after backing up any personal stuff.
On the web there are phone numbers and email support for ZTE

I’ve reset. Leiaplayer plays 3D photos no problem but only 2 sec of 3E video in 3D then crashes it will play entire 2D video

I am not support just a user, try them first, but you could remove the app store and reinstall it, then see if all the other apps are up to date, also is the system up to date.
Does the tablet work normally, if it does it could just be a app problem.
Please look through early posting on how to remove the app store and install it ,or it may not deinstall.
Hope this helps