Sep 2023 Leia Viewer Update broke the 3D

I just updated Leia viewer to the latest version to see if I could identify any bug fixes, and I encountered two new bugs right away.

  1. When you load a model, 3D mode initiates, but it does not display in 3D. Until you adjust the depth slider on the right. As soon as you move the slider a bit, the model begins to display in 3D.

  2. When you close out of the app , there is a noticeable able delay on the tablet home screen before the tablet reverts to 2D mode. You can tell it is still in 3D mode (3D resolution) and after about a second the screen blinks and it reverts to 2D.

The update was on my Nubia Pad 3D. I have not tried it on the Lume Pad 2 yet


Experience the same issue plus a few other problems.
I can browse the sketchfab explorer but when I try to download a model it says “You need an internet connection.” which I have otherwise I couldn’t browse the models in the first place.
Also where has the sketchfab account login gone? Can’t find it anymore.
There are also a few UI/localization (German) issues.

Edit 23/09/26
Sketchfab problems can be solved by clearing app data.

1 Like

Sketchfab explorer and login works after clearing the app data.
Problems with 3D not showing initially when loading 3d models from files or Sketchfab persist.
Also UI is not hideable with a tap in those cases.

These problems (3d and UI) don’t occur with the pre-installed demo models and didn’t occur at all with the previous version.

Same here on a Lume Pad 2.

Lighting and RGB color adjustments are also broken. Another major bug.