Can’t access Sketchfab

When I open LeiaViewer and tap on Sketchfab Explorer - I am getting the message ‘Request failed Unable to access Sketchfab website’. I think this happened after the latest software update. Has anyone else found this and if so, any solutions?

1 Like

Hi checked on original Lumepad and Nubia Pad 3D, loads on both

Message for Nima at Leia Inc. Looks like no one else has this problem but I am still getting the error message when trying to access Sketchfab. Is there anything else I could try? The problem appeared after I updated the software on my Nubia pad last week. Many thanks. Andy

I rechecked Sketchfab on my updated Nubia Tab 3D, I can login and it works ok

Many thanks for the update. I have tried again and am still getting the same error message. I can load models that I have downloaded from Sketchfab previously, but as soon as I hit the Sketchfab button, I get the message Request failed: unable to access Sketchfab website. I have tried powering off and then on again, but still same problem. Am hoping staff at Leia can suggest something that will get it working again. Once again, many thanks. Andy

I just downloaded a model OK.
I hope support get it sorted out

I am getting the error message, too. Unable to access Sketchfab Explorer, website in LeiaViewer, on the LP2.

@Awoodhead, @3D_Dave, please reach out to

1 Like

Problem solved! I have access to Sketchfab again - many thanks if this is something you fixed for me - or perhaps it just sorted itself?! Glad to be able to access Sketchfab again anyway. Thank you.

I have just got access again to Sketchfab via LeiaViewer after about a week of getting error message. Not sure why the problem occurred so not sure what to suggest - keep trying?

I still get the message here and there