SR Service Unity Not Responding When Importing Leia SDK

i just recently started to use the Leia SDK on Unity
but somehow when i imported the SDK there is this thing about SR Service Not Responding
even when i tried to import it in an empty project the same thing happens
i already follow the instruction in the doc to set the project
so i dont know how to fix this

also i tried to build the apk of the example scene (Leia Logo)
but somehow the 3D feature doesnt work in my device (Nubia pad)

Best regards

Hello Haqqi,

Thank you for posting this question. Lets start by ensuring you are on the latest version of Services and Plugin.

To start, we do acknowledge finding the latest version is not the easiest at this moment as our website is being redesigned. We hope this post unblocks you and other developers and we appreciate your patience as this information is streamlined.

SR Service

To check your SR version, please:

  • Opening the hidden icons in your dashboard, double clicking the SR Dashboard
  • Click About

At the time of writing, the latest version is The important number is 1.28

If you have v1.27 or below, please download the latest SR Platform here:


Apologies in advance for the need to create an extra account. We are working on consolidating our services. For now, this will unblock you from ensuing your windows services are working as expected.

Unity Plugin

Our latest plugins and documentation can be found here:

Hope this helps. Happy creating in 3D•AI!


i already checked my SR Service version and it’s already 1.28
i tried to reimport the Leia SDK again but the error still there
is there maybe something i missed in the project setting related to this SR Service?

That is worth checking. You can find our recommended settings at Windows > LeiaUnity > Recommended Unity Settings Window

Since you are targeting Nubia tablet, I am surprised SR Services is getting involved at all since that is used for Windows monitor communication - Android firmware uses a different firmware tool.

If you could provide:

  • Confirmation your Unity Plugin is the latest (V3.2.3 at the time of writing) in Assets/Leia/Resources/VERSION.txt
  • Confirmation your target platform is Android
  • Editor logs while your build issue is happening for the Numbia tablet

It will help me better troubleshoot your issue.

Thank you,