UE 5 SDK failed to load

Hi team, im facing some issue when trying to install the SDK for UE 5,

I have followed the step in the docs ( Manual Download And Import - Developer Docs ) , but after I copy the SDK, the error comes up, I t said plugin ‘LeiaUnreal’ failed to load.

So far here are some fixed that I have tried

  1. Create new blank Blueprint project and add c++ class
  2. Create new blank C++ project
  3. Rebuild the project in Visual Studio

so far none of them work, your help really appreciated, as I need the solution fast for my ongoing project.

Would you be able to share the latest engine log with us? This can provide more insight on what is going wrong.
You can find the log files here: [Project directory]\Saved\Logs

1 Like

here’s the project log , i have uploaded 2 logs , 1 empty new C++ project and 1 with on going project

It looks like the DLL is not loading correctly for some reason. We have tried on a few devices with different configurations, but were not able to reproduce this issue yet.

Are you able to run the project from Visual Studio? If so, please try the “Debug Editor” configuration.
Does this provide any additional information (think of console messages, asserts, etc).

ehmm im trying it now, will keep you updated

does this one the correct “debug editor” ?

im trying it on my other devices now, will keep you updated

Hello,

we have noticed a similar issue in the past with a previous version of our plugin, and the solution was posted here:

We understand recompiling the plugin is an extra step that ideally is not part of the workflow and are working on finding and resolving the source of the problem. In the meantime, please consider this process to unblock your development.

Happy creating,

Joe

Hi, actually the project is not opening, so I can’t do the recompile part. Is there any other way I can do ? I’ve try to install it on other machines, but the problem still the same.

based on the docs, is this the correct way to copy the plugins ?

Yes, that looks like the correct location for the plugin.

Would you be able to share a small sample project that demonstrates the issues? That would allow us to investigate the problem within our environment.

WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free here’s the project test link. Thank you

Hello Pejalan,

An interesting situation: the same project works on Sander’s computer without triggering the issue, I am currently setting up UE 5.3 to test on my side.

Since the project is the same and the result is different, I suspect there is a difference between Sander’s dev setup and yours.


On possible cause: In the past, we had a temporary solution to allow our tracking DLLs to work on UE5 that may be causing the issue. As I test this theory, can you check if you have a folder at

C:/LeiaTrackingDLLs/

If so, please:

  • Delete C:/LeiaTrackingDLLs/
  • Remove C:/LeiaTrackingDLLs/ from your Environment Variable’s ‘Path’
  • Restart your computer and try again

While we are working on reliably reproducing the issue, I cannot guarantee this is the source of the problem but it can at least remove it as a possibility

Thank you for replying back , I’ve checked all of my machine, there are no LeiaTrackingDLLs on the machines.

Ok, I am able to open the project and make a build without issue on my side, similar to Sander.

That leads me to believe our setup is different than yours where LeiaUnrealCore does not load.

Since we ruled out the LeiaTrackingDLL as a possible cause, my current theory is Service verison. Can you confirm your SR Service version by:

  • opening the hidden icons in your dashboard, double clicking the SR Dashboard
  • click About

Hi Joseph, i can’t find the SR dashboard, should I install it first from somewhere?

Yes, here is the latest version of the SR Platform, v1.28.1:
https://www.srappstore.com/

Apologies in advance for the need to create an extra account. We are working on consolidating our services. For now, this will unblock you from ensuing your windows services are working as expected.

Hopefully this resolves your issue. It’s my current theory as to why your same project would act different on our computers than yours.

thank you for the update, will try on it

1 Like

Hello Pejalan,

Wanted to follow up - did the service update resolve your issue?

Hi thank you, i have successfully compiled the APK, will let you know if I’ve found another issue. Thank you

1 Like