Module not Found & Undefined Symbol

Unity Engine 4.26.1 - Blueprint Only project target Mobile/Tablet
I followed the steps from the website and when I tried to launch on the device the unreal logo startup but then the application would fail saying it could not find the LeiaCamera module. I have the maps & modes setup to launch the FPS example scene from the plugins content. The plugin is enabled. I can see the plugin content in my content browser in the editor. I thought that maybe it needed to be a c++ project so I made a new project that was a c++ project

Unity Engine 4.26.1 - C++ project target Mobile/Tablet
Did the same things as I did above and instead I got deprecated warning on AttachTo in the Leia camera component script (377). Which stopped me from compiling so I just did what it asked and changed it to AttachToComponent. However now I am getting “ld.lld: error: undefined symbol: __aeabi_unwind_cpp_pr1”. No idea what that is.

Should I not be using UE4.26.1? What do you think is the issue?

1 Like

Hello Patrick,

Thank you for posting this issue. I was able to replicate the issue on my side:

  • Unreal Editor 4.26.2
  • Leia Unreal SDK: 00.00.04
  • Project Settings: Blueprint, Empty, Mobile
  • Level: Plugins/LeiaCamera/SampleLevels/FirstPersonExample

Result: Unity Icon appears, then a popup window

“Plugin ‘LeiaCamera’ failed to load because module ‘LeiaCamera’ could not be found. Please ensure the plugin is properly installed, otherwise consider disabling the plugin for this project”

I am exploring this issue and will let you know when I have more details / resolution.

Ok, so I was able to make a build. You were correct, the project being Blueprint based was the cause. After:

  • Creating an empty C++ based project, following the Setup Steps you mentioned above

  • Following all the steps in Building an Unreal Project

A project worked as expected. Until we can support Blueprint projects, we will update our documentation to prevent similar situations in other developer’s projects.

Thank you for helping us locate this issue!

3 Likes

Thanks for the response!

I made a new blank c++ project for Mobile/Tablet. Followed all the instructions in Building an Unreal Project however I got this unusual error “ld.lld: error: undefined symbol: __aeabi_unwind_cpp_pr1”. I dont understand this bug at all because idk why it needs to exist. I have done some research on this and this happened to someone else with a different plugin in Unreal (source). Someone suggested using this command “-fno-exceptions” but to be honest it was a little above my head. I didn’t know where that needed to be or what that command even is.

I have used other plugins before and have not run into this error. I have tried deleting it and started a new project and it just kept happening.

what your thoughts on this?

I said someone ran into the issue with another plugin, and I just reread through the source I provided… it looks like there’s was all their own code with no external libraries… so I guess not a great source, sorry about that.