I just ordered it Today after saving up every possible penny

I just ordered it Today after saving up every possible penny. You guys are the best. I LOVE 3D!!! SO EXCITED!!!


Welcome to Lume Pad @bombelkie! Can’t wait to see the content you create with it!

And as always, let us know if you have any questions or if we can help in some way.

1 Like

You have already helped out a lot just by existing. :relaxed: :grinning_face_with_smiling_eyes: :grin: :laughing: :sweat_smile: :rofl: :joy: :crazy_face:

Have Fun with it! The Best 3d Device! Even better with a Hydrogen one as Companion!

I received my Lume Pad today and am beyond excited. It truly is the best 3D device out there. How do you make the Lume Pad Home Screen Go 3D? I followed the video and it doesn’t work for me. has that been discontinued?

@bombelkie welcome ! Just to make sure this is the video that explains how to turn on immersive home screen mode:

The immersive mode is a special way to use the display where you benefit from the full resolution yet observe a nice parallax effect. It won’t let you put an arbitrary 3D background though, just the predefined patterns for now.

Let us know if you keep having trouble we’re here to help !

Yes that’s the video I followed @dfattal when I tap and hold that option doesn’t happen this pop’s up.

Then when I click on the styles & wallpaper it takes me to this screen.

The option isn’t there.

P.s. the live wallpaper picker doesn’t seem to work or is installed according to my apps.

Hey @bombelkie please make sure your Lume Pad is fully updated! Check in your Settings app to see if there are newer versions of the OS available for you to download.

I checked it’s up to date. This is the update it says.

Is there anything else I should do? I still don’t have that choice.

Hey @bombelkie, the team is looking into the bug, but there is a workaround one of our team members seems to have found:

  1. Tap and hold on the Home Screen, tap Wallpapers, should take you to Live Wallpapers (it will be empty), then tap the Square app switcher button and close that window.

  2. Go to the Settings app > Display > Wallpapers > Live Wallpapers (it will be empty)

  3. Hit the System back arrow so you’re on “Choose wallpaper from” and see Live Wallpapers and Wallpapers

  4. Tap Wallpapers

  5. Should launch into Immersive Wallpapers


Thank you for your response, I followed the instructions to the T and am sorry to say it didn’t work. It’s not the end of the world. It’s not a deal-breaker whats so ever just was curious to see that aspect of it in action. :grinning: I :smiling_face_with_three_hearts: the tablet anyway.

Well our team is on the case to squash this bug, when you get the next Lume Pad OS update soon hopefully it’ll be fixed!

No problem at all. :blush: