Set-up Android SDK path to make Android remote work

Every time I press play in unity the console says:

Set-up Android SDK path to make Android remote work

What am I missing?
Do I have to have android studio installed?

Hi Jim,
I have a follow up question for you. Are you able to build your apk to device or do you get the same error with the Android SDK? If you do get the same error when you build, take a look at your external tool settings in Unity Preferences. Make sure that you either have the corresponding SDK, JDK, and NDK installed either through Unity (By using the check boxes) or through an external application like Android studio (By setting the correct file path).

It might also be worth double checking you have android support installed by looking at your Unity version it Unity Hub.

1 Like

Ok, in general it looks good. But I see two things in your log one being the “InvalidOperationException” and the other being the SDK warning. You might try manually entering the link to the Android SDK to wherever it is installed on your computer i.e. uncheck the box and copy paste the path from file explorer. A helpful link to that is here: That will hopefully solve your SDK warning.

I suggest fixing the warning first to see if that resolves the errors but in the event that it doesn’t, there are a couple Unity posts about that file name error. Here is one from the forums: as well as one from Unity Answers: The general theme seems to be something with VS. There are a couple solutions the Answers page lists. Set VS code again as the text editor for Unity, reseting the arguments (also located in Unity external editor settings), or go to Package Manager and reset packages to default.

I think I need JDK 8 but I can’t download it off the oracle website because of technical difficulties.
Although I just downloaded JDK 15 just before that.

I got it to work by unchecking the box and re-linking the android sdk location

Then I loaded this tutorial project:

and then added LeiaCamera to the camerabrain under camerarig.
That works insofar as I can change convergence distance and baseline scaling but everything slows down to the point of being unplayable.

1 Like

Maybe an original android tutorial project would work better then :point_up_2: this one converted to android…