Update VaRest plugin?

I am still stuck with nothing from a UE build running. I’ve tried a standard game configuration to no avail. When I ran it in debug it appeared to complain about the VaRest plugin not being there?! This is a UE4 plugin. Is it necessary. What might be going wrong. I still can’t connect to the server.

Hello Wendysarrett,

This is new issue we have not come across yet. Lets start by honing in on the source of the issue.

Confirming Android Build (without our Plugin)

  • Open a new UE project. From your comment I assume you are using 4.26 or 4.27. I tend to use the Third Person Template
  • Confirm your Android SDK Setup (Edit > Project Settings > Platforms > Android SDK) This is what works on my machine but I defer to Unreal’s documentation for Android SDK Setup

Assuming your Android SDK is set up correctly and the rest of your Android Settings (Project Settings > Platforms > Android) look appropriate, try building to your connected Leia device.

If you face any issues up to this point, it suggests an issue with your project settings or Android SDK setup. Please resolve them before importing our plugin. If all goes well, you should see content in 2d on your Leia device.

Building A Leia Lightfield Level

Once you are able to build an android application, lets build a simple Lightfield Map.

Import our plugin, following our online documentation.

Once imported, navigate to (LeiaCamera Content > Sample Levels > Camera Setup > CameraSetupPerspective.umap) This is a basic level to show depth.


Add this map to your Default Maps (Edit > Project Settings > Project > Maps and Modes)


After following the rest of our Required Build Settings your should be able to see the sample content in Lightfield 3D on your Lightfield device.

Well I finally got it working. It seems (and I finally noticed) that it was using the android 24 sdk when 23 is the max. I went into android studio and uninstalled 24 and installed 23 and it would then build. I was able to get the perspective level working once I realized when I used those levels it blew away some of the package settings (odd behavior…it wanted to use the camera then it crashed.) Once I fixed the settings it started working again and did indeed come in in 3d. Thank you again!! I will have to experiment some more with the camera and the instructions for using stereo cameras in cinema.

1 Like