Viewing content from SD Card in Leia Player

I am trying to view some (SBS) 3D content that I have stored on my SD Card in Leia Player. If I “Share” from the Files app to LP, it says it “Cannot convert from other apps” and just plays it in 2D. Other times it gives me a message saying “Can’t find camera roll folder”. When I try to locate the file from the File Browser within Leia Player itself, it only lets me browse the device’s internal storage.

With that said, how can I view this content without having to move it to the device’s internal storage?
Thanks in advance!

1 Like

For now you must move files to the device’s internal storage or for videos play back from an app like NOVA Video Player.

This may change in a coming update.


Thanks! Hopefully SD support will come in a future update. I have moved the video files to the internal storage and have run into another issue. Leia Player plays the video - but with no sound whatsoever. NOVA seems to play the sound just fine, so the issue seems to be specific to Leia Player. Do you know what might be causing this?

Thanks again!

1 Like

LeiaPlayer only supports the most popular video and audio codecs. If you got this file from a file sharing service, it often will come with codecs chosen for a specific purpose, which would either be for serious file compression or for lossless quality, both spectrums use codecs that are different from the popular ones which are designed to be more balanced.

It’s my own file (i.e. not from a file sharing service), which has an uncompressed DTS-HD track. I’m assuming this doesn’t fall under the supported codecs for LeiaPlayer?

I would much like SD card access too. I’m confused what to do now with 200GB of 3D movies I have I was looking forward to keeping on the Lume Pad for travel. The SD doesn’t seem to mount if it’s formatted ExFAT and if I format it in the Lume Pad (2) it won’t read in my Mac. If I try to use Android transfer for Mac it seems unhappy about >4GB files, and meanwhile in LeiaPlayer it won’t see the SD card anyway. I’m kinda confused as to exactly what the SD card slot is good for really, with these limitations

I have a Mac and have no problem loading 3D movies onto the LP2. There is lots of storage space, on the device - I’m using 54GB of space, for video - and the SD card adds more. I use the Android File Transfer app, on the Mac, that recognises the LP2, when it’s connected with the USB cord. Once on the LP2, I use the Google Files app to transfer the movies to the SD card. It seems to delete the movie file from the LP2 storage, once the file is transferred to the SD card. Evidently, the SD card will not handle files larger than 4GB, so not all of my files could be transferred, but I only did this as an exercise, when I read, in a different thread, that the NOVA video app for Android, can play video, stored on the SD card, through LeiaPlayer. I plan to re-encode some of my 3D videos in h265, to reduce the file size, so they will transfer to the SD card.

I personally use a NAS and use QFile to browse and download whatever I want directly from my personal server. But any sort of cloud or local storage solution like that would work.

Ultimately, Lume Pad 2 is a mostly-stock Android device, and has all the limitations of stock Android. Though some other companies have worked beyond those limitations, they have spent countless hours and dollars to do so. Since we’re in the 3D business, not the file system formats business, we’re pretty limited in what we’re going to spend our time building.

I strongly recommend just using wireless transfer if your files are greater than 4GB. If they’re less, then of course there’s no issues.

Hi Nima, I guess what I’m confused about is what file system is it actually using? If “format” on the Luma Pad 2 is making it FAT32 then why won’t my Mac read it? If it’s EXT3 or 4 those formats don’t have a 4GB limit (apparently) so whilst I get you aren’t a file system company what I was fishing for was someone to say “oh, you need to format it this way on X app” or on a windows PC or something.

Either that, or apparently Android 13 will support ExFAT. Do you plan to support that? I’d prefer that to downgrading my movie files essentially, which seems to be the alternate.

The fact Leia Player won’t see the SD card also is something I was hoping you guys had on your feature list essentially,

Thanks, Rich

1 Like

SD card support would be great - or just say it won’t be supported. Clarity is needed.

Full MicroSD card support (the same file system formats as the stock Android OS) will be in a future LeiaPlayer update. We have no plans to add it to other applications at this time.

1 Like

Thanks, looking forward to it. Would be good to be able to select multiple files so that we can see all of the pictures without going back to open each one individually. Appreciate your work.

1 Like

I agree, it would be wonderful to be able to just scroll through photos stored in the micro sd card in 3D mode without having to open them up one at a time.

An SD card is ok for images that you want to keep on the tablet, but it’s a pain to insert/remove. I’ve been using a USB drive to hold images, but have to copy them to internal storage to view them. Looking forward to the standard file system interface in LeiaPlayer.

I just tested a USB-C thumb drive with NTFS format and it works. You can format the drive easily from Windows or Linux (I think for Mac you might need a third party app). I was able to copy over a 7GB video and it was fine. Interestingly, I could play the video with Leia Player, but it was not able to convert to 3D.

1 Like

@cybereality Thanks for the info. Just to clarify: you didn’t copy the video from the USB thumb drive into Lume internal memory before viewing? Of course not being able to view it in 3D is a bit of a problem.

1 Like

Yes, I was able to play the video directly from the Google Files app by clicking it and choosing open in Leia Player. The video did play, but it was very slow to buffer (it was a 7GB 4K video). After a few seconds it played fine, but when scrubbing though the video it paused again. When I clicked the 3D button it says “cannot convert to 3D from external apps”.

I am having difficulty in playing my 3d files in 3d on the lume pad2 . I transfer them to the internal storage and they play side by side and pressing the 3d button does not do anything. Btw I have installed a 1tb sd card with no issues thanks Simon

Hey Simon, please make sure your Lume Pad 2 and all your apps (mainly the Leia FaceTracking app and LeiaPlayer) are fully updated. There is a known bug for non-updated devices and apps which makes 3D unstable.

After that, your content should just play in 3D without issue. If it’s still not being detected, you can use the “Add 3D Media Tag” option in the Ellipsis (three vertical dots) menu in the top right when the content is playing, or just rename the file with _2x1.mp4 or _2x1.jpg at the end of the filename.

1 Like

Brilliant that works thank you :+1: