LeiaPlayer 4.3 is now available

The update you’ve all been waiting for is now here! LeiaPlayer now supports browsing a MicroSD card, VR180/360 photos, pinch to zoom for photos, double tap to fill for videos, and more!

Here are the official release notes:

LeiaPlayer 4.3.41785 Release Notes
• MicroSD/USB-C Storage Support
• VR180/360 Photo Support
• Pinch to zoom support for photos
• Double tap to fill support on photos and videos
• Significantly reduced app size
• Increased loading speed for 3D media
• Requires Leia DisplayConfig v0.7.86 or higher
• Requires Leia FaceTracking v0.7.79 or higher
• Requires Leia MediaService v0.5.22 or higher

This is the one the team has been working on for nearly half a year now, and it’s the biggest LeiaPlayer update in history!

We hope you love it! Let us know what you think.


And for those who asked, we’ve fixed the tags for auto-reconvergence behavior, so you can manually enable/disable it.

LIF, LVF, MPO, VR180, and 3D 360 content all have auto-reconvergence on by default. You can disable auto-reconvergence by adding “_noreconv” to the filename of your media.

SBS has auto-reconvergence off by default. You can force auto-reconvergence on by adding “_reconv” to the filename of your media.

If you’re wondering why it works the way it does by default, we tested thousands and thousands of files of different types and found that 95%+ of the time, the defaults we chose make the content look much better. So we’re doing it for the people who would be confused by having to make choices about whether or not to use auto-reconvergence. But if you’re reading and understanding this, you’re smart enough to use the filename tags :slight_smile:


Why is leai player so buggy when attempting to select external drives and browse, is there a cache of the entire drive taking place in the background initially? Player often gets stuck and is unresponsive and media wont play. I have done some further testing and found that I have to let the drive “load” all of the thumbnails for all of the media before I can even get anything to attempt to play. I have a large drive with a ton of 3D movies and I hope this is a one-time cache thing because waiting for the player to “load” everything before I can even attempt to play a file seems very unoptimized. Anyway to fix this? Also FAT32 is not a proper format to use these days, with the max file size of 4GB its basically useless for any modern media, let alone high quality VR videos.

Yes, it caches the thumbnails, names, and locations of the files so you can browse them in the file browser.

That is expected behavior. You can try use a drive with less files on it if you’d like the process to finish faster. Or, alternatively, use a faster drive. I currently have a nice 1TB MicroSD card with about half a terabyte of storage (mostly 3D movies and VR video files) and it fully caches in less than 20 seconds upon first load.

Then don’t use FAT32? Both ExFAT and NTFS are supported for reading files, you just can’t write files / move files onto those drives.

1 Like

I agree with everything above except the amount of time it took to cache my media on my microsd card. I am using a 1 TB sandisk extreme A2 V30 card with over 500GB of media and it took a couple of minutes to load the first time. Perhaps this is not the latest and greatest card by todays standards but everything else seems to be working fine now. Thanks for confirming.

1 Like

Oh, and before I forget:

If anyone is looking to use external storage, I recommend using a MicroSD card formatted to the ExFAT file system format. This will allow you to browse and read the files in LeiaPlayer without any file size limitations, and it’ll load fast.

And if you ever want to move files onto it, you can simply use the File Manager app that comes on Lume Pad 2 and it’ll allow you to write files to the MicroSD card too, which makes it easy to offload files that are filling up your internal storage as needed, and move them back and forth as needed quickly.


This is a bit confusing.

Just to confirm, are you saying that the Lume Pad 2 can write files / move files onto an ExFAT drive but only with the File Manager app.

1 Like

ExFAT and NTFS aren’t really supported in Android OS by default.

The File Manager app has Read/Write support for ExFAT.

LeiaPlayer has Read support for ExFAT but not Write support.


All these additions were highly anticipated and super welcome ones. Another one I love that isn’t in the release notes above, is the depth slider + focus editing that was implemented for 2D photos that are converted locally in LeiaPlayer to 3D. It works beautifully, yielding far better results than similar tools on the original lume pad. Also so happy to finally have 180 photo support.

Two things that would be great to see in the future are:

  1. depth slider for videos that are converted to 3D using LeiaPlayer. The default level of depth comes out a bit too flat for me, which is why I don"t use the feature now, but if a slider were added I can see myself using it on a daily basis.

  2. Manual view adjustment by tapping and dragging for 180VR photos and videos (which is possible when viewing 180VR videos in 3D on LeiaTube), would be a great addition at some point. I’ve seen this mentioned already elsewhere in these forums, so chances are it would be appreciated by others that will using LeiaPlayer to view 180 VR media.

Amazing work with these updates!

I just need the swipe to move option on the leia player for VR video and I will finally be golden with all my needs.

Please release this next update with that feature as soon as possible haha

It is an amazing update! However I’m bit lost with the message I get when using my SanDisk Extreme Pro 512 GB: it was formatted in the past under my Windows computer and I’ve got the message “Micro SD Card File Format not Fully supported”. The message states that to enable full features I had to format the external storage in the “Storage” section of the device settings or using Fat32 file format. Then I have formatted in the “Storage” section as per suggestion, but the message is still there. And in fact any conversion I perform appears in the device “download” section and not in the same folder of the original photo as it was supposed. What I’m doing wrong?

Only FAT32 is fully supported, but it has the major limitation that you can’t use files over 4GB. So I actually recommend using ExFAT, though with that format, you can’t write files to it using LeiaPlayer, instead you have to use the File Manager app.

It may be retaining its original file format when formatting. Use a PC if you want to switch to FAT32 and it’s not working in the Settings app.

This is occurring because the file format you’re using isn’t fully supported and LeiaPlayer isn’t able to write files to it.

1 Like

Thank you for the clarification. The new version is simply amazing: I’m viewing tons of old videos and pictures of my children in the SD card converted immediately in 3D in excellent way. Great work.

1 Like

Is the caching done once on the entire drive? Or every time the drive is opened? Or is it only when a folder with enclosed media is opened?

I have to say, the speed with which conversions work AND the quality that comes out of it is absolutely remarkable.

Thanks for all the efforts.

It’s done once upon first connection. If you disconnect and reconnect it will re-cache.

1 Like

Ah good to know. Thank you for clarifying!

This is great news, but how do I get it to work? I tried to access my current micro sd card on my Lume2 and it says the file format is not fully supported. It says go to settings and storage to format, but there is no “storage” in my settings to work with!

I tried to format the micro sd on my PC but only have exFAT, NTFS, or 128kb as options