Unparalleled 3D experience, big struggle to load content

Leia Developers / 3D Team,

Firstly, I’d like to extend my appreciation for the incredible work you’ve done with the 3D experience on the tablet. Truly, the immersion and depth it provides without the need for a headset is unmatched and showcases the potential of where technology can take us.

However, I’ve recently encountered some massive hiccups. For reasons unknown to me, my tablet seems to struggle with loading 3D content. There’s a visible attempt, but it doesn’t render. This became particularly evident (and unfortunately timed) when I tried showcasing it to a potential client and the content failed to load, which was a bit disappointing. :expressionless:

I just did a factory reset since all my other efforts failed.

I believe in the product despite the friction and am eager to show it off at an upcoming event, especially for attendees who might be hesitant to use VR headsets. I understand that technology isn’t always flawless, but I do hope this feedback helps in further refining the experience for users.

Thank you for your dedication and hard work. I look forward to seeing the continued evolution of the product.

Warm regards,

Flow City

What kind of content was it? File type and resolution/framerate? What app? If LeiaPlayer, which version?

Had the same issue a few weeks ago out of nowhere with all 3d apps across the board.

LeiaPlayer/LeiaPix would show only in 2d image or just a black screen.
LeiaViewer would load only a teenytiny distorted something in the center of a black screen.

After a factory reset everything went normal again but I lost lots of the demo images/videos.

Where/How can I download them? :grimacing:

Reach out to help@leiainc.com

Will do.
Thanks for you quick response :+1:

Exact same thing for me across the whole tablet. Resetting it worked.

1 Like

This happened to me twice over the past 3 weeks. But a factory reset was not required. Just did a regular restart and let it cool down for a little bit.

1 Like